解决Vue中安装sass-loader和node-sass版本匹配的报错

  • 内容
  • 相关

报错原因是可能会存在的:就是直接安装也会安装最新版本的
npm install node-sass --save-dev //安装node-sass
npm install sass-loader --save-dev //安装sass-loader
安装完成后就会运行

网上说是因为sass-loader安装的版本太高,卸载重新安装低版本即可,网上大部分都是安装的7的版本,我装的是7.3.1

所以解决方法很简单如果你是我上面那种安装方式之一而且正好报错的话请用我接下来献上的解决方法

先卸载之前的sass-loader node-sass版本
npm uninstall sass-loader
npm uninstall node-sass -D

然后重新装7.3.1 sass-loader的版本 由于sass-loader期望的node-sass值为^4.0.0:所以我们满足他这个小小的愿望,安装sass-loader@7.3.1和node-sass@4.13.1版本

npm install sass-loader@7.3.1 --save-dev
npm install node-sass@4.14.1 --save-dev


本文标签:

版权声明:若无特殊注明,本文皆为《z》原创,转载请保留文章出处。

本文链接:解决Vue中安装sass-loader和node-sass版本匹配的报错 - https://www.52zzk.cn/post-129.html

发表评论

电子邮件地址不会被公开。 必填项已用*标注